Opened 10 years ago

Closed 9 years ago

#4780 closed bug (fixed)

Accordion: text doesn't wrap around a floated linked image in IE

Reported by: rdworth Owned by:
Priority: major Milestone: 1.8.2
Component: ui.accordion Version: 1.7.2
Keywords: accordion zoom float img IE text wrap Cc:
Blocked by: Blocking:

Description

In IE, if you have an IMG with float:left inside an A inside an accordion content, text will not wrap around the right of the image as it would when not in an accordion, and there will be whitespace instead. This is caused by the following code, in ui.accordion.js:

// IE7-/Win - Extra vertical space in lists fixed
if ($.browser.msie) {
	this.element.find('a').css('zoom', '1');
}

Requires the following work-around:

$('.ui-accordion-content a:has(img)').css('zoom', '');

Perhaps this code is no longer needed, with the fix in #4444 ?

Attachments (1)

accordion_a_zoom_1.html (1.5 KB) - added by rdworth 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by rdworth

Attachment: accordion_a_zoom_1.html added

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8
Priority: minormajor

Need to test what that zoom-workaround was supposed to fix, and if that is actually covered by the fix for #4444.

comment:2 Changed 9 years ago by Scott González

Milestone: 1.91.8.2
Resolution: fixed
Status: newclosed

This was fixed in a previous release. Likely in r3039 for #4444.

Note: See TracTickets for help on using tickets.