Opened 10 years ago

Closed 7 years ago

#4812 closed bug (duplicate)

Sortable: Text wraps when added to tabs that have subpixel widths

Reported by: tan Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.7.2
Keywords: CSS, tabs, sortable Cc:
Blocked by: Blocking:

Description

Using Firfox 3.5.2 MacOS X

  1. Go to the demo page, http://jqueryui.com/demos/tabs/#sortable
  2. Use the UI Lightness theme
  3. Drag the Aenean lacina tab

When the dragging occurs the label text breaks.

eg.

Aenean lacina

Expected: The text should not break.

Note: This does not happens with all the themes, like Trontastisc.

Change History (5)

comment:1 Changed 10 years ago by tan

Sorry, I thought the system created linebreaks at newlines

Correction to problem description:

--- eg.

Aenean
lacina

---

comment:2 Changed 10 years ago by Scott González

Component: CSS Frameworkui.sortable
Milestone: TBD1.8

This is a sub-pixel calculation problem. I can see that the width of a specific tab is 75.4667px but drops down to 75px during drag.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:4 Changed 7 years ago by mikesherov

Status: newopen
Summary: Text breaks when sortable is added to tabsSortable: Text wraps when added to tabs that have subpixel widths

comment:5 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed

Duplicate of #8882.
Closing this as a duplicate of #8882 because this is caused by the use of parseInt within the sortable plugin.

Note: See TracTickets for help on using tickets.