Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4839 closed bug (duplicate)

Slide effect causes scripts re-evaluation in affected area

Reported by: nbelaevski Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.effects.* (individual effect) Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Usage of "slide" effect causes re-evaluation of all scripts in the animated area and this leads to re-creation of JavaScript objects, re-attaching event handlers, etc with undesired side effects. This problem affects number of our components (e.g. http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4253686#4253686 and is major for us, as we are going to fully migrate to jQuery in the near future).

Please see attached test case: alert should not be called if "Click me!" is clicked. Here is the line of jQuery.UI that causes the problem:

element.wrap('<div class="ui-effects-wrapper" style="font-size:100%;background:transparent;border:none;margin:0;padding:0"></div>');  

Attachments (3)

slide.html (784 bytes) - added by nbelaevski 10 years ago.
drop.html (783 bytes) - added by shadowcreeper 10 years ago.
drop effect also causes this
scale.html (784 bytes) - added by shadowcreeper 10 years ago.
scale effect also causes this

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by nbelaevski

Attachment: slide.html added

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

comment:2 Changed 10 years ago by Jörn Zaefferer

Component: ui.coreeffects.* (individual effect)

comment:3 Changed 10 years ago by shadowcreeper

This also affects other effects such as "drop" and "scale".

Changed 10 years ago by shadowcreeper

Attachment: drop.html added

drop effect also causes this

Changed 10 years ago by shadowcreeper

Attachment: scale.html added

scale effect also causes this

comment:4 Changed 10 years ago by shadowcreeper

Note: These 3 are the only effects I tried and they are all affected.

comment:5 Changed 9 years ago by Corey Frang

Resolution: duplicate
Status: newclosed

comment:6 Changed 9 years ago by Corey Frang

Duplicate of #3677.

Note: See TracTickets for help on using tickets.