Opened 10 years ago

Closed 7 years ago

#4841 closed bug (wontfix)

Dialog over pdf document embedded in iframe does not display correctly

Reported by: rotoflex Owned by: rotoflex
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.7.2
Keywords: dialog, pdf, iframe Cc:
Blocked by: Blocking:

Description

Dialog does not display correctly in Firefox (3.5.2) when it is displayed over pdf document embedded in iframe. Dialog content displays over pdf document but titlebar and small portion of dialog's frames stay under pdf document.

When ui-dialog-content and ui-widget-content are added as titlebar's class, titlebar displays correctly but this also causes dialog to lose it's draggable effect.

Change History (15)

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

Could be something about position:relative. A testpage would be nice.

comment:2 Changed 10 years ago by slobo

It seems that in Firefox 3.5.5 (Linux) it will render div content on top of PDF plugin if it has overflow:auto (or one of overflow-x or overflow-y set to auto). Adding this to .ui-dialog style improves the rendering (border and padding of dialog are still hidden), but it also make dragable dialogs movement erratic. Solution seems to be that we need to envelop the whole ui-dialog into another div (sizing of which needs to be handled manually, not sure how well moving/resizing would work). This wrapper div need have no style other than overflow:auto, but we must be careful not to actually produce any scrollbars around it

In case of using modal dialogs, then just the overlay needs overflow:auto. Note that this will cause all of PDF plugin to hide when overlay is placed on top of it (as if it's replaced with a transparent div)

comment:3 Changed 8 years ago by Scott González

Owner: set to rotoflex
Status: newpending

Please provide a reduced test case showing the problem so we can see how you're embedding the pdf.

comment:4 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 Changed 8 years ago by rotoflex

Hi,

Here's test case for this http://jsbin.com/imevek. As you can see page contains simple iframe with pdf embedded in it. If you drag dialog over pdf you'll see it will go behing iframe. I've tested this with IE9, Chrome 18.0.1025.168 and Firefox 12.0 and Firefox is the only browser that dialog will stay on top of iframe.

Regards,

Janne

comment:6 Changed 8 years ago by Scott González

Resolution: invalid
Status: closedreopened

Works for me in Chrome 20, Chrome 18 just downloaded the file instead of displaying it.

comment:7 Changed 8 years ago by rotoflex

Strange, my Chrome 18 displays pdf instead of downloading it. I noticed that if I use Chrome's internal PDF viewer dialog stays on top but with Adobe Acrobat is will stay under iframe.

comment:8 Changed 8 years ago by rotoflex

Unfortunately most of our clients use Internet Explorer from version 7 to 9 so it would be really helpful to get this working on it.

comment:9 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:10 Changed 7 years ago by mikesherov

Status: reopenedopen

comment:11 Changed 7 years ago by Jörn Zaefferer

Is there a reliable way to reproduce this? What software exactly has to be running?

comment:12 Changed 7 years ago by mikesherov

joern, see comment 6 for a test case.

comment:13 Changed 7 years ago by Jörn Zaefferer

That works fine in Chrome 23 on OSX. In Firefox 16, it starts downloading the PDF, and there's still nothing on top of the dialog.

comment:14 Changed 7 years ago by mikesherov

http://jsbin.com/imevek shows the failure in IE9 on browserstack for me. However, I really think this should be a wontfix, as pdf display isn't really part of the "web", so to speak, and the fix would involve yet another iframe hack. Thoughts?

comment:15 Changed 7 years ago by Scott González

Resolution: wontfix
Status: openclosed

Jörn: I think you'd need to install the Acrobat plugin to see the broken behavior.

But, as was discussed recently (and mentioned by Mike above), we won't support this.

Note: See TracTickets for help on using tickets.