Opened 10 years ago

Closed 9 years ago

#4855 closed bug (worksforme)

datepicker wrong position in firefox near right page side

Reported by: asen Owned by:
Priority: major Milestone: 1.8
Component: ui.datepicker Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

1) datepicker placed near right side of page
2) page have vertical scrollbar
3) in firefox 3.5.3 (and maybe other versions)
i see right side of datepicker below scrollbar (wrong)

in IE all working well

code to reproduce (from demo)

<!doctype html>
<html lang="en">
<head>
	<link type="text/css" 
 href="http://jqueryui.com/themes/base/ui.all.css" 
 rel="stylesheet" />
	<script type="text/javascript" 
 src="http://jqueryui.com/jquery-1.3.2.js"></script>
	<script type="text/javascript" 
 src="http://jqueryui.com/ui/ui.core.js"></script>
	<script type="text/javascript" 
 src="http://jqueryui.com/ui/ui.datepicker.js"></script>
	<link type="text/css" 
 href="http://jqueryui.com/demos/demos.css" 
 rel="stylesheet" />
	<script type="text/javascript">
	$(function() {
		$('#datepicker').datepicker({
			numberOfMonths: 3,
			showButtonPanel: true
		});
	});
	</script>
</head>
<body>
<div 
 style="background: #eeeeee; float: right; width: 250px; height: 800px;"> 
<div class="demo">
<p>Date: <input type="text" id="datepicker"></p>
</div><!-- End demo -->
</div>
</body>
</html>

Change History (4)

comment:1 Changed 9 years ago by Jörn Zaefferer

Milestone: TBD1.8
Priority: minormajor

Datepicker should use the (new) positionTo utility which includes collision detection.

comment:2 Changed 9 years ago by kbwood

Unable to reproduce in FF 3.5.5 - the datepicker aligns its right edge with the scroll bar.

comment:3 Changed 9 years ago by btburnett3

Unable to reproduce in trunk 1.8rc1 using Firefox 3.0.17, 3.5.7, or 3.6.

comment:4 Changed 9 years ago by Scott González

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.