Opened 10 years ago

Closed 10 years ago

#4865 closed bug (fixed)

maxDate Firefox 3.5.2 issue - calendar locked

Reported by: idlesign Owned by:
Priority: major Milestone: 1.8
Component: ui.datepicker Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

The following code should set maxDate of '#pea_date_ret' to the date one month after the date selected at '#pea_date'.

It works fine in IE6 and Opera 9.64, but not in Firefox 3.5.2. In Firefox '#pea_date_ret' is locked at current month (navigation is not available).

	    $('#pea_date').datepicker({
	       onSelect: function(text, inst) { 
		    var max_date=new Date(parseInt(inst.currentYear), parseInt(inst.currentMonth)+1, parseInt(inst.currentDay));
		    $('#pea_date_ret').datepicker('change', {
			defaultDate: $('#pea_date').datepicker('getDate'),
			maxDate: max_date
		    });
		}
	    });

Change History (6)

comment:1 Changed 10 years ago by idlesign

Title typo "Firefox 3.5.2", not "Firefox 2.5".

comment:2 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8
Priority: criticalmajor
Summary: maxDate Firefox 2.5 issue - calendar lockedmaxDate Firefox 3.5.2 issue - calendar locked

comment:3 Changed 10 years ago by kbwood

Unable to reproduce in FF 3.5.5.

comment:4 Changed 10 years ago by idlesign

Oops seems to be in boolean returned by _isInRange() method.

comment:5 Changed 10 years ago by btburnett3

Unable to reproduce, looks to me like it was fixed in r3671 by kbwood when fixing #5026

comment:6 Changed 10 years ago by Scott González

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.