Opened 10 years ago

Closed 6 years ago

#4875 closed bug (wontfix)

Sortable: fails if li element has overflow set to auto

Reported by: haydenchambers Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.7.2
Keywords: firefox, sortable, overflow Cc:
Blocked by: Blocking:

Description

to reproduce in firefox 3.5

the key is the overflow:auto of the li (without overflow its a visual disaster because of the floating content)

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">

<html lang="en">
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	<title>test</title>
	<script src="http://www.google.com/jsapi"></script>
	<script type="text/javascript">
		google.load("jquery","1.3.2");
		google.load("jqueryui","1.7.2");
	</script>
	<script type="text/javascript">
		$(document).ready(function() {
			$("ul").sortable();
		});
	</script>
	
	<style type="text/css">
		ul { width:300px;padding:10px;border:1px solid black; }
		li { border:1px solid red;overflow:auto; }
		li span { float:left; }
		.tool { float:right; }
	</style>
</head>
<body>
	<ul>
		<li><span>list item 1</span><span class="tool">x</span></li>
		<li><span>list item 2</span><span class="tool">x</span></li>
		<li><span>list item 3</span><span class="tool">x</span></li>
		<li><span>list item 4</span><span class="tool">x</span></li>
		<li><span>list item 5</span><span class="tool">x</span></li>
	</ul>
</body>
</html>

sort: function() { console.log("sorting"); }

reveals two calls before the li 'sticks' to the the mouse and further logs fail

Change History (3)

comment:1 Changed 9 years ago by Jörn Zaefferer

Milestone: TBD1.8

comment:2 Changed 6 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 6 years ago by petersendidit

Resolution: wontfix
Status: newclosed
Summary: sortable fails if li element has overflow set to autoSortable: fails if li element has overflow set to auto

Thanks for taking the time to contribute to the jQuery UI project! I was able to recreate this problem in Firefox 3.6 with this: http://jsfiddle.net/petersendidit/fDTUJ/1/ But it looks like the bug is not reproducible in Firefox 4.0+.

If you have a fix fore the problem in Firefox 3.5 feel free to submit a pull request on github.

Note: See TracTickets for help on using tickets.