Opened 10 years ago

Closed 10 years ago

#4898 closed bug (fixed)

$.ui.dialog.overlay: Too many events disabled

Reported by: mkemmerling Owned by:
Priority: major Milestone: 1.8
Component: ui.dialog Version: 1.7.2
Keywords: Cc: markus.kemmerling@…
Blocked by: Blocking:

Description

The $.ui.dialog.overlay widget disables events on base of the event target's parent '.ui-dialog' element's z-index. This will also disable key events whose target happen to be the '.ui-dialog' itself, i.e copying with <CTL>-C. This can easily be verified with the modal dialog demo on the jQuery UI website.

Explicitely including the '.ui-dialog' element as possible event target fixes the problem. The attached ui.dialog.js patch adds .andSelf() at the approbiate position.

Attachments (1)

ui.dialog.js.patch (544 bytes) - added by mkemmerling 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by mkemmerling

Attachment: ui.dialog.js.patch added

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8
Priority: minormajor

comment:2 Changed 10 years ago by duelli

We also had this problem with ui.dialog and copy-pasting under WinXP and FF. As far as I known we have not seen these problems with WinXP and IE or Linux and FF, though.

I can confirm that the attached patch works as intended and solves copy-pasting from a ui.dialog with WinXP and FF.

Please fix this for release 1.8!

comment:3 Changed 10 years ago by btburnett3

This is also fixed by the fix to #4363, r3757. The zIndex() method checks the target as well as the parents to get the zIndex, so events directly on the ui.dialog will be allowed to proceed.

comment:4 Changed 10 years ago by Scott González

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.