Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4929 closed bug (fixed)

ThemeRoller Not Working

Reported by: kschneider Owned by:
Priority: critical Milestone:
Component: [meta] ui.downloadbuilder Version: 1.7.2
Keywords: ThemeRoller Cc:
Blocked by: Blocking:

Description

Custom themes are not currently working when using the ThemeRoller. The file that is downloaded doesn't have a css folder and in the themes/custom-theme folder it is empty. I have also tried using the FireFox plugin with similar results.

Here is one of the url's I've been using but I've tried several different ones as simple as choosing a pre-built theme and just changing one color and attempting to download. I've tried downloading the pre-built themes and they all work fine.

http://jqueryui.com/themeroller/#ffDefault=Verdana%2C+Arial&fwDefault=bold&fsDefault=1.1em&cornerRadius=0px&bgColorHeader=525252&bgTextureHeader=01_flat.png&bgImgOpacityHeader=25&borderColorHeader=333333&fcHeader=ffffff&iconColorHeader=ffffff&bgColorContent=ffffff&bgTextureContent=01_flat.png&bgImgOpacityContent=25&borderColorContent=666666&fcContent=666666&iconColorContent=8A8A8A&bgColorDefault=333333&bgTextureDefault=01_flat.png&bgImgOpacityDefault=20&borderColorDefault=212212&fcDefault=eeeeee&iconColorDefault=cccccc&bgColorHover=616161&bgTextureHover=01_flat.png&bgImgOpacityHover=40&borderColorHover=212121&fcHover=ffffff&iconColorHover=ffffff&bgColorActive=ffffff&bgTextureActive=01_flat.png&bgImgOpacityActive=30&borderColorActive=212121&fcActive=666666&iconColorActive=8A8A8A&bgColorHighlight=ededed&bgTextureHighlight=01_flat.png&bgImgOpacityHighlight=80&borderColorHighlight=212121&fcHighlight=666666&iconColorHighlight=5ba220&bgColorError=fff0cc&bgTextureError=01_flat.png&bgImgOpacityError=40&borderColorError=ffb73d&fcError=424242&iconColorError=e86f17&bgColorOverlay=5c5c5c&bgTextureOverlay=01_flat.png&bgImgOpacityOverlay=50&opacityOverlay=60&bgColorShadow=cccccc&bgTextureShadow=01_flat.png&bgImgOpacityShadow=30&opacityShadow=60&thicknessShadow=6px&offsetTopShadow=-6px&offsetLeftShadow=-6px&cornerRadiusShadow=0px

Change History (15)

comment:1 Changed 10 years ago by kschneider

I forgot to mention that I tried this using IE7, FireFox 3.5, and Chrome 3.0.

comment:3 Changed 10 years ago by made

I have the same problem. If I try to create a custom theme it is not included in the zip downloaded. I tried various combinations before downloading, customizing the folder name and the CSS Scope of the theme, but without result.

comment:4 Changed 10 years ago by Lawouach

Same here (seems rather logical of course) but wanted to chime in as this prevents from using the theme roller (aside from including the individuals css which are part of the development bundle).

comment:5 Changed 10 years ago by Andy99Andy99

I have also been experiencing the same problem. It started happening for me on 10/27/2009. I have tried Firefox 3.5, IE7 and Chrome 3.0 with similar results. Could someone please look into this?

Thanks,

Andrew Wright

Here is the URL of the custom theme I was trying to build:

http://jqueryui.com/themeroller/#ffDefault=Verdana%2CArial%2Csans-serif&fwDefault=bold&fsDefault=1.0em&cornerRadius=0px&bgColorHeader=cccccc&bgTextureHeader=03_highlight_soft.png&bgImgOpacityHeader=75&borderColorHeader=aaaaaa&fcHeader=222222&iconColorHeader=222222&bgColorContent=ffffff&bgTextureContent=01_flat.png&bgImgOpacityContent=75&borderColorContent=aaaaaa&fcContent=222222&iconColorContent=222222&bgColorDefault=e6e6e6&bgTextureDefault=02_glass.png&bgImgOpacityDefault=75&borderColorDefault=d3d3d3&fcDefault=555555&iconColorDefault=888888&bgColorHover=dadada&bgTextureHover=02_glass.png&bgImgOpacityHover=75&borderColorHover=999999&fcHover=212121&iconColorHover=454545&bgColorActive=ffffff&bgTextureActive=02_glass.png&bgImgOpacityActive=65&borderColorActive=aaaaaa&fcActive=212121&iconColorActive=454545&bgColorHighlight=fbf9ee&bgTextureHighlight=02_glass.png&bgImgOpacityHighlight=55&borderColorHighlight=fcefa1&fcHighlight=363636&iconColorHighlight=2e83ff&bgColorError=fef1ec&bgTextureError=02_glass.png&bgImgOpacityError=95&borderColorError=cd0a0a&fcError=cd0a0a&iconColorError=cd0a0a&bgColorOverlay=aaaaaa&bgTextureOverlay=01_flat.png&bgImgOpacityOverlay=0&opacityOverlay=30&bgColorShadow=aaaaaa&bgTextureShadow=01_flat.png&bgImgOpacityShadow=0&opacityShadow=30&thicknessShadow=8px&offsetTopShadow=-8px&offsetLeftShadow=-8px&cornerRadiusShadow=8px

comment:6 Changed 10 years ago by ShahidHFaruqi

Not working for me either. Very strange indeed.

comment:8 Changed 10 years ago by iantearle

Same here. This is frustrating, surely this worked before, must be a simple change for the UI team to get it back working, and this is surely a major functionality for them to fix quicker than what they are?

comment:9 Changed 10 years ago by jkolesnik

I am also having this same problem. I see that there is currently not a "custom theme" option in the theme drop-down of the download page which is hopefully a sign that the issue is being worked on.

comment:10 Changed 10 years ago by rich36

I was able to download and use my custom theme. I think things are working ok now.

comment:11 Changed 10 years ago by rdworth

Component: [meta] ui.themeroller[meta] ui.downloadbuilder
Resolution: fixed
Status: newclosed

Fixed by clearing cache on server.

comment:13 in reply to:  11 Changed 10 years ago by mattweg

Replying to rdworth:

Fixed by clearing cache on server.

I've been having this issue again for the last few days. Themeroller downloads are missing the correct css and no images are generated.

comment:14 Changed 10 years ago by _Andreas_

Hello mattweg,

the themes are not working (CSS is missing some parts). Could you please clear the servers cache again?

It's not only the custom themes. The defaults themes aren't working either!

Many thanks in advance _Andreas_

comment:15 Changed 10 years ago by cjmuk

I'm currently having the same problem. Redmond, Start, Humanity and Flick have all been missing a CSS folder. But strangely Cupertino and another attempt at Redmond worked...

comment:16 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.