Skip to main content

Search and Top Navigation

#4929 closed bug (fixed)

Opened October 27, 2009 08:19PM UTC

Closed October 31, 2009 12:37PM UTC

Last modified October 11, 2012 09:15PM UTC

ThemeRoller Not Working

Reported by: kschneider Owned by:
Priority: critical Milestone:
Component: [meta] ui.downloadbuilder Version: 1.7.2
Keywords: ThemeRoller Cc:
Blocked by: Blocking:

Custom themes are not currently working when using the ThemeRoller. The file that is downloaded doesn't have a css folder and in the themes/custom-theme folder it is empty. I have also tried using the FireFox plugin with similar results.

Here is one of the url's I've been using but I've tried several different ones as simple as choosing a pre-built theme and just changing one color and attempting to download. I've tried downloading the pre-built themes and they all work fine.

Attachments (0)
Change History (15)

Changed October 27, 2009 08:27PM UTC by kschneider comment:1

I forgot to mention that I tried this using IE7, FireFox 3.5, and Chrome 3.0.

Changed October 28, 2009 11:52AM UTC by made comment:3

I have the same problem. If I try to create a custom theme it is not included in the zip downloaded. I tried various combinations before downloading, customizing the folder name and the CSS Scope of the theme, but without result.

Changed October 28, 2009 01:32PM UTC by Lawouach comment:4

Same here (seems rather logical of course) but wanted to chime in as this prevents from using the theme roller (aside from including the individuals css which are part of the development bundle).

Changed October 28, 2009 02:30PM UTC by Andy99Andy99 comment:5

I have also been experiencing the same problem. It started happening for me on 10/27/2009. I have tried Firefox 3.5, IE7 and Chrome 3.0 with similar results. Could someone please look into this?


Andrew Wright

Here is the URL of the custom theme I was trying to build:

Changed October 28, 2009 04:54PM UTC by ShahidHFaruqi comment:6

Not working for me either. Very strange indeed.

Changed October 29, 2009 08:45AM UTC by iantearle comment:8

Same here. This is frustrating, surely this worked before, must be a simple change for the UI team to get it back working, and this is surely a major functionality for them to fix quicker than what they are?

Changed October 30, 2009 11:51AM UTC by jkolesnik comment:9

I am also having this same problem. I see that there is currently not a "custom theme" option in the theme drop-down of the download page which is hopefully a sign that the issue is being worked on.

Changed October 30, 2009 03:43PM UTC by rich36 comment:10

I was able to download and use my custom theme. I think things are working ok now.

Changed October 31, 2009 12:37PM UTC by rdworth comment:11

component: [meta] ui.themeroller[meta] ui.downloadbuilder
resolution: → fixed
status: newclosed

Fixed by clearing cache on server.

Changed January 26, 2010 12:11AM UTC by mattweg comment:12

Replying to [comment:11 rdworth]:

Fixed by clearing cache on server.

I've been having this issue again for the last few days. Themeroller downloads are missing the correct css and no images are generated.

Changed February 10, 2010 08:32PM UTC by _Andreas_ comment:13

Hello mattweg,

the themes are not working (CSS is missing some parts). Could you please clear the servers cache again?

It's not only the custom themes. The defaults themes aren't working either!

Many thanks in advance


Changed April 02, 2010 02:02AM UTC by cjmuk comment:14

I'm currently having the same problem. Redmond, Start, Humanity and Flick have all been missing a CSS folder. But strangely Cupertino and another attempt at Redmond worked...

Changed October 11, 2012 09:15PM UTC by scottgonzalez comment:15

milestone: TBD

Milestone TBD deleted