Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4948 closed bug (wontfix)

Datepicker does not work in FF & Safari with "body { overflow:scroll }"

Reported by: Ghommey Owned by:
Priority: minor Milestone:
Component: ui.datepicker Version: 1.7.2
Keywords: overflow Cc: jquery_bug@…
Blocked by: Blocking:

Description

A vertical CSS scrollbar causes a bug ( seems to be a dimension problem )

This bug can easily be reproduced by copying the sample code of jqueryUI and adding 2 lines css declarations:

 body { overflow:scroll }
 #datepicker{ position:absolute; right:1px }

The result is here: http://jsbin.com/obami/ (Click at the textbox located on the right side)

The right part of the calendar is not clickable as it is out of the window and using the x-axis scrollbar hides the calendar.

Bug can be seen using on Mac OS X with Firefox 3.5, Safari 4.0, Opera 9.2 and with Windows using Firefox 3.5

Internet Explorer does not cause this bug ( probably because the vertical scroll bar is always shown )

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: wontfix
Status: newclosed

We don't support pages that modify how the body is displayed.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.