Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#4978 closed bug (duplicate)

IntegrityError: (1062, "Duplicate entry 'madangryscienti-1-query_href' for key 1")

Reported by: madangryscientist Owned by:
Priority: minor Milestone:
Component: [meta] ui.site Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a GET operation on /report/1, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'1'}

System Information

Trac 0.11.1
Python 2.4.3 (#1, May 24 2008, 13:47:28)
[GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]
setuptools 0.6c5
MySQL server: "5.0.45", client: "5.0.45", thread-safe: 0
MySQLdb 1.2.2
Genshi 0.5.1
mod_python 3.2.8
Subversion 1.4.2 (r22196)

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 222, in dispatch
    req.session.save()
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/session.py", line 102, in save
    "VALUES(%s,%s,%s,%s)", attrs)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/db/util.py", line 57, in executemany
    return self.cursor.executemany(sql_escape_percent(sql), args)
  File "build/bdist.linux-i686/egg/MySQLdb/cursors.py", line 218, in executemany
  File "build/bdist.linux-i686/egg/MySQLdb/cursors.py", line 312, in _query
  File "build/bdist.linux-i686/egg/MySQLdb/cursors.py", line 276, in _do_query
IntegrityError: (1062, "Duplicate entry 'madangryscienti-1-query_href' for key 1")

Change History (3)

comment:1 Changed 9 years ago by Jörn Zaefferer

Component: ui.core[meta] ui.site

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #2973.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.