Opened 9 years ago

Closed 4 years ago

#4994 closed feature (worksforme)

Draggable: Add support for dir="rtl"

Reported by: inamjameel Owned by: inamjameel
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I am using JQuery Drag n drop, tabs, dialog boxes etc in my Stock trading application. its functioning fine in ltr css direction. the problem is all the Drag n drop operations are handled through, relative absolute positioning and handles Left, Top property of the css to handle widgets place. i want to enable this (drag n drop) functionality in rtl css direction too. please let me know if there is already a support available in the Jquery 1.3. or any suggestion to optimize the solution if i have to implement it in rtl direction by transforming left to right and vice versa.

Change History (15)

comment:1 Changed 7 years ago by Scott González

Type: enhancementfeature

comment:2 Changed 6 years ago by Scott González

Milestone: TBD2.0.0

comment:3 Changed 6 years ago by Jörn Zaefferer

Status: newopen

Need to take RTL into account for 2.0.0. Usually browsers are pretty smart about RTL and hardly require us to support it directly.

comment:4 Changed 6 years ago by Scott González

Owner: set to inamjameel
Status: openpending

What exactly is the request? How does LTR affect dragging? Is this a request to support using right instead of left?

comment:5 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:6 Changed 6 years ago by leen

Hi, I have the same issue. I am using jquery-1.6.2 and jquery.ui.draggable to use JQuery Drag n drop. its functioning fine in ltr css direction. When I used rtl direction, I have a problem while dragging the image, position of the mouse when I clicked into the image to begin drag change. please let me know if there any suggestion to optimize the solution if i have to implement it in rtl direction by transforming left to right and vice versa.

Thanks

comment:7 Changed 6 years ago by Scott González

leen: It's not possible for us to provide any help until we get more information. See my unanswered questions in comment 4. A reduced test case goes a long way.

comment:8 Changed 6 years ago by hri

hello, i have same issue as leen, i'm using ie8, jquery-1.6.2 and jquery.ui.draggable

the problem is when i'm using ltr direction the drag is not accurate.
The mouse pointer is far away from the dragged object.

please help

Thanks in advanced

Last edited 6 years ago by hri (previous) (diff)

comment:9 in reply to:  8 Changed 6 years ago by tj.vantoll

Replying to hri:

hello, i have same issue as leen, i'm using ie8, jquery-1.6.2 and jquery.ui.draggable

the problem is when i'm using ltr direction the drag is not accurate.
The mouse pointer is far away from the dragged object.

please help

Thanks in advanced

We need a reduced test case that shows the issue you are experiencing. You can use this as a starting point: http://jsfiddle.net/tj_vantoll/kY7FA/.

comment:10 Changed 6 years ago by mojehfilm

could you please have look at : http://jsfiddle.net/q9Zq4/

comment:11 Changed 6 years ago by hri

I tried it in http://jsfiddle.net/hhri/kY7FA/5/
But i can't make the problem show. In my case i have to scroll the dragged object all over the background image, for that i have a scroll bar and i think that what causes my problem, because when i set the main div width to 100% everything works fine

Last edited 6 years ago by hri (previous) (diff)

comment:12 Changed 6 years ago by tj.vantoll

Resolution: invalid
Status: closedreopened
Summary: Drog n Drop Support in RTL directionDraggable: Add support for dir="rtl"

Thanks mojehfilm.

Here's a test case http://jsfiddle.net/tj_vantoll/wruxS/.

comment:13 Changed 6 years ago by hri

hello,

Any news for this issue?

Thank you

comment:14 in reply to:  13 Changed 6 years ago by tj.vantoll

Replying to hri:

hello,

Any news for this issue?

Thank you

The draggable interaction is set for a rewrite in 1.13 and we will likely not be investigating this before then. If you'd like to look into this yourself we'd be happy to review a pull request.

comment:15 Changed 4 years ago by Scott González

Resolution: worksforme
Status: reopenedclosed

This is not a bug with RTL. The helper is absolutely positioned, so it doesn't have the same width as the original. The positioning is correct, since positioning is always based on the top left corner. See http://jsfiddle.net/wruxS/1/ for a simple solution with the provided test case.

Note: See TracTickets for help on using tickets.