Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#5010 closed bug (duplicate)

Dialog memory leak (1.3.2 / 1.4a1)

Reported by: malsup Owned by:
Priority: major Milestone:
Component: ui.dialog Version: 1.7.2
Keywords: memory leak Cc:
Blocked by: Blocking:

Description

Not sure if this is an issue with core or with the ui Dialog class, but displaying the dialog over and over causes excessive memory leakage in IE. Tested in IE8.

Sample test page which shows the problem:

http://test.malsup.com/dialog/

The mem leak also occurs when using blockUI instead of Dialog so it may be a problem in core. Tested with both 1.3.2 and 1.4a1 with same results.

Drip.exe also shows tons of leaked DOM elements.

I also created a ticket in the core tracker: http://dev.jquery.com/ticket/5666

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4565.

comment:2 Changed 8 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.