Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5036 closed bug (duplicate)

removeClass that affects background-color transitions to wrong colour

Reported by: gregwmay Owned by:
Priority: minor Milestone:
Component: ui.effects.core Version: 1.7.2
Keywords: removeClass Cc:
Blocked by: Blocking:

Description

My attached sample page has a CSS-styled black background. I have chained an addClass and a removeClass together to make a highlight effect... the affected class changes the background colour to Red.

On calling removeClass, it transitions to white rather than black, finally switching back to black once the animation is complete.

Additional minor point: I am unable to chain addClass and removeClass using regular addClass().removeClass(), instead having to use the callback function in addClass to call removeClass. Not sure if this is as intended.

Attachments (1)

ticket_5036.html (900 bytes) - added by gregwmay 10 years ago.
sample HTML file showing the problem

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by gregwmay

Attachment: ticket_5036.html added

sample HTML file showing the problem

comment:1 Changed 10 years ago by gregwmay

My workaround for this is to use the jQuery animate function to manipulate backgroundColor, however using classes is preferred because my application uses variable background colours.

comment:2 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4372.

comment:3 Changed 10 years ago by Scott González

Component: effects.* (individual effect)effects.core

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.