Opened 10 years ago

Closed 7 years ago

#5068 closed bug (duplicate)

Sortable: drag doesn't work with flash inside the container

Reported by: kof Owned by:
Priority: major Milestone: 2.0.0
Component: ui.sortable Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

There is an issue with ui.sortable.js. If the container you want to drag has an <embed/> tag inside it stops after dragstart.

A similar issue was described here http://groups.google.com/group/jquery-ui/browse_thread/thread/1e8b3cfbecc5de7b/bf06acfc76354d94?lnk=gst&q=Draggable+issued+with+Embedded#bf06acfc76354d94

Seems to be a bug of firefox on mac.

Here is a demo without any unnecessary stuff:

http://dev.ajaxsoft.de/test/dd-forum.html

Thanks

Attachments (1)

dd-forum.html (1.2 KB) - added by kof 10 years ago.
demo

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by kof

Attachment: dd-forum.html added

demo

comment:1 Changed 10 years ago by kof

Ups, there is my nickname in the title because of copy&paste :)

comment:2 Changed 10 years ago by kof

I have a workaround now:

  1. There is no problems by dragging the original element
  2. If we want to use a helper, we can't change some properties of the original item, for e.g. css prop position or display. To hide the original item we have to set overflow:hidden; and hight:0 .

comment:3 Changed 10 years ago by Jörn Zaefferer

Priority: blockermajor

comment:4 Changed 7 years ago by Scott González

Milestone: TBD2.0.0

comment:5 Changed 7 years ago by mikesherov

Status: newopen
Summary: oleg008 sortable issue with flash inside of the containerSortable: drag doesn't work with flash inside the container

confirmed on latest: http://jsfiddle.net/RQbD3/ Draggable works, sortable doesn't.

comment:6 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed

Duplicate of #5048.

Note: See TracTickets for help on using tickets.