Opened 10 years ago

Closed 9 years ago

#5080 closed bug (notabug)

ie8 highlight errors after some time

Reported by: paulvb Owned by: paulvb
Priority: minor Milestone: 1.9.0
Component: ui.effects.* (individual effect) Version: 1.8a1
Keywords: highlight ie7 effect Cc:
Blocked by: Blocking:

Description

i am using jQuery UI 1.8a1, and when i highlight a div in IE8 , I get the error below error: Invalid property value. jquery-ui.js, line 3976 character 3

See testcase:

<style>

div.x{ width: 100px; height: 100px; background: black; float: left;

margin-left: 50px; color: #fff } </style> <div class="x">test 1</div> <div class="x">test 2</div> <div class="x">test 3</div>

<script> $(function() {

setInterval( function(){

$('.x').show('highlight', {}, 1000);

},3000); });

</script>

Change History (5)

comment:1 Changed 10 years ago by dmethvin

The problem is the "background:black" part of the style. The color animation doesn't support color names.

comment:2 Changed 10 years ago by rdworth

Milestone: TBD1.8

I'm not sure that's it. jQuery UI Effects core has support for color names. Perhaps try background-color instead of background? A test page would help assess.

comment:3 Changed 10 years ago by paulvb

I created a testcase. I also changed the css property to background-color. No success..

http://test.preview.variabele.nl/test/index.html

comment:4 Changed 9 years ago by Corey Frang

Owner: set to paulvb
Status: newpending

Made a fiddle of the testcase: http://jsfiddle.net/gnarf/GR7ht/ I was unable to reproduce any script errors in IE8 - Is this still a problem?

comment:5 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.