Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5106 closed bug (worksforme)

Wrong params in callback

Reported by: insekticid Owned by:
Priority: critical Milestone: 1.8
Component: ui.autocomplete Version: 1.8rc1
Keywords: Cc:
Blocked by: Blocking:

Description

When I want to access item params in callback function - object in object is given

Now

$('#ac_ajax').autocomplete({'select':function (event, item) { $("#country_code").val(item.item.id); }});

Patched

$('#ac_ajax').autocomplete({'select':function (event, item) { $("#country_code").val(item.id); }});

Attachments (1)

autocomplete-callback-params.patch (875 bytes) - added by insekticid 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by insekticid

comment:1 Changed 10 years ago by Scott González

Resolution: worksforme
Status: newclosed

This is functioning as intended and as documented.

comment:2 Changed 10 years ago by insekticid

Could you pls send me link to the documentation? Because here http://jqueryui.com/demos/autocomplete/ is nothing about it

Note: See TracTickets for help on using tickets.