Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5125 closed bug (notabug)

On IE, pressing enter automatically triggers a click event on an unfocused button

Reported by: benjamin.neau Owned by:
Priority: critical Milestone:
Component: ui.button Version: 1.8rc1
Keywords: button, focus, click, ie, internet explorer, msie, automatic, unexpected Cc: benjamin.neau@…
Blocked by: Blocking:

Description

When no element is focused, pressing enter will result in:

  • [On IE8] Clicking the very first button of the page (the one labelled "Simple button, only text")
  • [On IE6/7] Clicking the submit button (the one labelled "Submit button")

There is no such bug on FF 3.6 and Chrome 3.0.

The bug can be experimented on the button component visual tests page : http://jquery-ui.googlecode.com/svn/branches/dev/tests/visual/button/default.html.

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: invalid
Status: newclosed

This is not a bug, this is how IE behaves. You'll get the exact same behavior even without any of the jQuery files loaded.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.