Opened 8 years ago

Closed 7 years ago

#5165 closed bug (notabug)

Incorrect calender in March 1984

Reported by: jk Owned by: jk
Priority: major Milestone: 1.9.0
Component: ui.datepicker Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

There are only 3 days in March 1984.

Attachments (1)

Datepicker.png (10.5 KB) - added by jk 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by jk

Attachment: Datepicker.png added

comment:1 Changed 8 years ago by kbwood

I'm not seeing this on the demo site. What timezone is your PC set to? And when does daylight saving/summer time start/end there?

comment:2 Changed 8 years ago by jk

We tested on Windows XP in IE, Firefox, Opera. It works fine. But on Linux Mint 7, Ubuntu 9 in Firefox 3.5.7, Google Chrome 4.0.249.43 calender is shown incorrectly. We have GMT+6 time zone.

comment:3 Changed 8 years ago by Scott González

Milestone: TBD1.8
Priority: criticalmajor

comment:4 Changed 8 years ago by kbwood

I don't have this environment to test with.

comment:5 Changed 8 years ago by Merry

Found same bug with March 1983 and March 1982. (Seems like only first row is displayed).

Tested on Opensuse 11.1 with Firefox 3.6.3 and Opera 10.10.

I'v changed:

	/* Find the number of days in a given month. */
	_getDaysInMonth: function(year, month) {
		return 32 - new Date(year, month, 32).getDate();
	},

with

	/* Find the number of days in a given month. */
	_getDaysInMonth: function(year, month) {
		return new Date(year, month+1, 0).getDate();
	},

And this solve the problem for me.

comment:6 Changed 8 years ago by kbwood

I'm not seeing this on the demo site either. What timezone is your PC set to? And when does daylight saving/summer time start/end there?

comment:7 Changed 7 years ago by cmhdave

Try as I might I am unable to reproduce this bug. I installed openSUSE 11.4 on my spare laptop, set the timezone to GMT+6 and tried with both Firefox and Opera with no luck. Can you confirm this is still an issue? If so can you give a little detail about how Datepicker is set up and how the bug is reproduced? When I go to the Datepicker Demo and try to browse to 3/1984 with the month/year select boxes, the month display comes up fine.

comment:8 Changed 7 years ago by rdworth

Owner: set to jk
Status: newpending

comment:9 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.