Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5176 closed bug (notabug)

Found an issue in trunk version of jquery.autocomplete.js

Reported by: Rwhitbeck Owned by:
Priority: blocker Milestone: 1.8
Component: ui.autocomplete Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have found an issue with the latest (r3795) version of jquery.autocomplete.js. It is actually in the ui.menu widget that it in that file.

You can see the problem if you setup a simple ajax autocomplete and mouse over the results - a javascript error occurs.

The error occurs because of line 333-ish in the refresh function:

.mouseenter(function() {

self.activate($(this).parent());

});

At this point in the code, 'self' is a reference to the window object, rather than the menu object.

The problem is eliminated by declaring self at the start of the refresh function:

refresh: function() {

var self = this;

...

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: invalid
Status: newclosed

Closing invalid; fixed but never released.

comment:2 Changed 10 years ago by Scott González

To clarify, the bug was never released, closed invalid just to ensure it doesn't show up on the changelog.

Note: See TracTickets for help on using tickets.