Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5218 closed bug (duplicate)

memory leak problem on ie

Reported by: L_K_W Owned by:
Priority: major Milestone:
Component: ui.dialog Version: 1.8rc2
Keywords: ie memory leak Cc:
Blocked by: Blocking:

Description

hi,I am using jquery 1.3.2 and ui 1.7.2, and trying to upgrade to jquery1.4.2 and ui1.8, but both versions seem to have the memory leak problem on ie6 and later. There are a lot of setting forms on my page in the form of ui modal dialog, but each time i open a new dialog, the old dialog memory seems not been released, i tried a lot of method(e.g. destroy&remove) and no good result. just take the demo page for a simple example:

\jquery-ui-1.8rc2\jquery-ui-1.8rc2\demos\dialog\modal-form.html

each time click the button 'Create new user' open the form, \dM's memory increase shows in the task manager. i tried to add the following line to the ready function and it seems works.

$('#msieleak').live('pleak',function(){});

another effective way is comment out the following line in dialog.js.

this.instances.push($el);

Could anyone please explain this, and the demo page is simple but what should i do in my page when i have a lot of dialogs, please?

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5185.

The problem is that IE eats memory when using opacity and there's no way that we know of to prevent it. Our solution was to reuse overlays to reduce the amount of memory used.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.