Opened 10 years ago

Closed 7 years ago

#5240 closed bug (wontfix)

Arrow keys don't work on datepicker field in Opera 9.64+

Reported by: Eyeless Owned by: Eyeless
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Pressing arrow keys on field with attached datepicker does nothing. Ctrl+arrow combinations still work. Appears in every Opera version from 9.6, including 10.50 beta. All other major browsers work properly.

Change History (10)

comment:1 Changed 10 years ago by Scott González

Milestone: TBD1.8

comment:2 in reply to:  description Changed 9 years ago by vadim.keller

_doKeyPress event handler filters out keys with codes 35,36,37,39 (END,HOME,LEFT,RIGHT). In Opera it prevents default action.

comment:4 Changed 8 years ago by kAlvaro

The issue is more than cosmetic since some other keys are affected, including DEL or F5.

Test case: http://jsbin.com/eqarur

comment:5 Changed 8 years ago by Jörn Zaefferer

Status: newopen

Still valid. That pull request did not help.

comment:6 Changed 8 years ago by mrozik

tested in Opera 12.00 and kzys's pull request solved the problem (Ctrl + ArrowKeys, ArrowKeys works). Yet, Opera still filters AltKey + ArrowKeys, and doesn't even fire any of key events...

comment:7 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:8 Changed 7 years ago by Scott González

Owner: set to Eyeless
Status: openpending

I updated the test case to use actual version numbers: http://jsbin.com/eqarur/3/edit

The ticket was filed against 1.7.2, but the test case used 1.8.13 (and latest core + latest theme).

I'm not seeing any problems in current Opera (12.14). Is this just no longer a problem or is the test case or bug description not adequate?

comment:9 Changed 7 years ago by Eyeless

Status: pendingnew

Tried the test case with latest Opera, looks like it is working now and issue is no longer actual. Should there be any actions from me according to the issue lifecycle?

comment:10 Changed 7 years ago by Scott González

Resolution: wontfix
Status: newclosed

Nope, thanks for confirming. I'll close as wontfix since it now applies only to browser we no longer support.

Note: See TracTickets for help on using tickets.