Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5248 closed bug (duplicate)

New Button, Radio style triggers each onclick event twice

Reported by: thaddeus Owned by:
Priority: blocker Milestone:
Component: ui.button Version: 1.8rc2
Keywords: radio Cc:
Blocked by: Blocking:

Description

New Button, Radio style triggers each onclick event twice!

when I run the following code:

The alert comes up twice.

<script type="text/javascript">

$(function() { $("#radio1").buttonset(); });

</script>

<form> <div id="radio1"> <input type="radio" id="radio1" name="radio" value="rd1" onclick="alert(this.value);" />

<label for="radio1">Choice 1</label>

<input type="radio" id="radio2" name="radio" checked="checked" value="rd1" onclick="alert(this.value);" />

<label for="radio2">Choice 2</label>

<input type="radio" id="radio3" name="radio" value="rd1" onclick="alert(this.value);" />

<label for="radio3">Choice 3</label>

</div> </form>

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed
Version: 1.8rc31.8rc2

Duplicate of #5195.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.