Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5256 closed bug (duplicate)

IntegrityError: (1062, "Duplicate entry '705bf3b751e5e92-0-query_time' for key 1")

Reported by: tomas Owned by:
Priority: minor Milestone:
Component: [meta] ui.dev Version:
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a GET operation on /query, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'col': [u'id', u'summary', u'owner', u'type', u'priority', u'version'],
 'component': u'ui.button',
 'ctl': u'query',
 'group': u'component',
 'max': u'250',
 'order': u'priority',
 'report': u'17',
 'status': [u'accepted', u'assigned', u'new', u'reopened']}

System Information

Trac 0.11.1
Python 2.4.3 (#1, May 24 2008, 13:47:28)
[GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]
setuptools 0.6c5
MySQL server: "5.0.45", client: "5.0.45", thread-safe: 0
MySQLdb 1.2.2
Genshi 0.5.1
mod_python 3.2.8
Subversion 1.4.2 (r22196)

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 222, in dispatch
    req.session.save()
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/session.py", line 102, in save
    "VALUES(%s,%s,%s,%s)", attrs)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/db/util.py", line 57, in executemany
    return self.cursor.executemany(sql_escape_percent(sql), args)
  File "build/bdist.linux-i686/egg/MySQLdb/cursors.py", line 218, in executemany
  File "build/bdist.linux-i686/egg/MySQLdb/cursors.py", line 312, in _query
  File "build/bdist.linux-i686/egg/MySQLdb/cursors.py", line 276, in _do_query
IntegrityError: (1062, "Duplicate entry '705bf3b751e5e92-0-query_time' for key 1")

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #2973.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.