Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5258 closed bug (duplicate)

show, hide, toggle with different speed then slow or fast do not work

Reported by: insekticid Owned by:
Priority: critical Milestone: 1.8
Component: ui.effects.core Version: 1.8rc3
Keywords: show hide toggle normal speed Cc:
Blocked by: Blocking:

Description

http://api.jquery.com/show/ last example is $("span,div").show("normal");

works with jquery but doesn't work with jquery + ui because, there is check for speed param $.fx.speeds[speed] on the line 4240 in jquery-ui.js

jquery 1.4.2
5293 jQuery.fn.extend({
5294 show: function( speed, callback ) {
5295 if ( speed || speed === 0) {
5296 return this.animate( genFx("show", 3), speed, callback); 

jquery ui 1.8rc3
4224 $.fn.extend({ 

4238 _show: $.fn.show,
4239 show: function(speed) {
4240 if (!speed || typeof speed == 'number' || $.fx.speeds[speed]) {
4241 return this._show.apply(this, arguments);
4242 } else {
4243 var args = _normalizeArguments.apply(this, arguments);
4244 args[1].mode = 'show';
4245 return this.effect.apply(this, args);
4246 }

Change History (2)

comment:1 Changed 10 years ago by Scott González

Component: ui.coreeffects.core
Resolution: duplicate
Status: newclosed

Duplicate of #5192.

comment:2 Changed 10 years ago by insekticid

#5192 is reason for this problem

$("span,div").show("normal");

your fix => $.fx.speeds[options] but there is no speed with name "normal" in jquery, but jquery accepts it!

jQuery.extend( jQuery.fx, { . . .

speeds: {

slow: 600,

fast: 200, Default speed _default: 400

},

Note: See TracTickets for help on using tickets.