Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5268 closed bug (duplicate)

dialog overlay bug

Reported by: gtrmitch Owned by:
Priority: critical Milestone:
Component: ui.dialog Version: 1.8rc3
Keywords: Cc:
Blocked by: Blocking:

Description

When using the dialog plugin in jquery 1.8rc3 I get this error when I hit the dialog multiple times (like open it, esc, try opening it, etc.) sometimes it's once, sometimes its 3 times:

b("<div></div>").addClass("ui-widget-overlay") is undefined

line: 199 in custom.min.js (everything was downloaded)

This is the code:

var dialog = "<div></div>";

$(dialog).dialog({

bgiframe: true, modal: true, title: title, close: function (event, ui) { $(this).remove(); if ($.isFunction(onClose)) { onClose(); } }, buttons: {

Ok: function () { $(this).dialog("close"); }

}

});

Change History (4)

comment:1 Changed 10 years ago by RobARichardson

Yep, this is a critical for me as well. Getting this a lot.

comment:2 Changed 10 years ago by mrecho

I've also have had this issue with every dialog that I have on my site. The 2nd time you activate the dialog() it will work.

comment:3 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5228.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.