Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#5285 closed bug (duplicate)

datepicker.parseDate doesn't handle short years properly

Reported by: Ivan Peters Owned by:
Priority: minor Milestone:
Component: ui.datepicker Version: 1.7.2
Keywords: parseDate Cc:
Blocked by: Blocking:

Description

The parseDate code appears to cheat slightly by assuming that each component will use the maximum number of digits or will have some sort of delimiter. In the case of the year, it assumes up to 4 digits which can be a problem for dates using this format:

yddmm

$.datepicker.parseDate("yddmm", "100105") will fail with "Missing number at position 6".

Change History (4)

comment:1 Changed 10 years ago by pheiberg

This should have been resolved by the fix for #6659.

comment:2 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Thanks, closing as a duplicate.

comment:3 Changed 10 years ago by Scott González

Duplicate of #6659.

comment:4 Changed 8 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.