Opened 10 years ago

Closed 10 years ago

#5293 closed bug (duplicate)

Themeroller: Icons do not save with custom "Theme Folder Name" set

Reported by: Rwhitbeck Owned by: mikehostetler
Priority: critical Milestone: 1.8
Component: [meta] ui.themeroller Version: 1.8rc3
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Rwhitbeck)

've used the themeroller several times in the past so I consider myself "comfortable" with it at this point.

I noticed my custom theme wasn't saving my icon images correctly, so while I was doing some debugging I realized if I left the "Theme Folder Name" at it's difficult setting "custom-theme" the images would save correctly. If I changed it to anything but the default the icon images wouldn't work.

Hope this helps.

Forum: http://forum.jquery.com/topic/themeroller-icons-do-not-save-with-custom-theme-folder-name-set

Change History (4)

comment:1 Changed 10 years ago by Rwhitbeck

Description: modified (diff)

comment:2 Changed 10 years ago by Rwhitbeck

Owner: set to mikehostetler
Status: newassigned

comment:3 Changed 10 years ago by PeteMorris

This description is slightly misleading. The forum has better information, so to clarify, the specific problem is not a jQuery UI issue but a PHP error. Most likely, either the server running themeroller has had PHP compiled without GD support, or perhaps there is a capitalisation issue, as the PHP manual says the function is "imagecolormatch", not "ImageColorMatch" and as I recall PHP is case sensitive.

Fatal error: Call to undefined function ImageColorMatch?() in /srv/jqueryui.com/htdocs/themeroller/images/phpthumb.filters.php on line 1040

Pete

comment:4 Changed 10 years ago by mikehostetler

Resolution: duplicate
Status: assignedclosed

Duplicate of #5290

Note: See TracTickets for help on using tickets.