Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5375 closed bug (fixed)

Dialog causes error if dialog is destroyed at least twice

Reported by: dakota Owned by:
Priority: critical Milestone:
Component: ui.dialog Version: 1.8rc3
Keywords: Cc:
Blocked by: Blocking:

Description

This is a strange, but easily repeatable bug.

If you create a dialog and then destroy it on close after number of times things start failing. The 1st and 2nd time it works fine. On the third time this error message appears:

$("<div></div>").addClass("ui-widget-overlay") is undefined

File: http://cmscout.co.za/testjs/js/jquery-ui-1.8rc3.custom.js
Line: 2527

Thereafter 2*n (Even) times it works and 2*n-1 (Odd) times it doesn't.

Test case is available at http://cmscout.co.za/testjs/

Change History (4)

comment:1 Changed 10 years ago by ajpiano

I could not duplicate this issue against the current SVN trunk

http://jsbin.com/ojece/3

comment:2 Changed 10 years ago by ajpiano

Resolution: fixed
Status: newclosed

This issue has already been addressed in trunk, closing this ticket.

comment:3 Changed 9 years ago by Scott González

Duplicate of #5228.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.