Opened 9 years ago

Closed 7 years ago

#5378 closed bug (invalid)

Nested draggables (with opacity set) in IE: helper not visible after dragging

Reported by: Lockhead Owned by: Lockhead
Priority: major Milestone: 2.0.0
Component: ui.draggable Version: 1.8rc3
Keywords: nested draggable Cc:
Blocked by: Blocking:

Description

The following code gives a problem when dragging the divs in IE (tested only version 8)

If you remove the opacity definition for the outer draggable it works without a problem.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<%@ page session="true" contentType="text/html; charset=UTF-8"
    pageEncoding="ISO-8859-1"%>
<html>
<head>
<title>TestPage</title>
<script src="../js/jquery-1.4.2.js" type="text/javascript"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.core.js"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.widget.js"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.mouse.js"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.button.js"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.sortable.js"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.draggable.js"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.droppable.js"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.resizable.js"></script>
<script type="text/javascript" src="../js/ui/jquery.ui.dialog.js"></script>
<style type="text/css">
#inner {
    width: 300px;
    height: 200px;
    background-color: #ff0000;
}

#outer {
    width: 600px;
    height: 800px;
    background-color: #000000;
}
</style>
<script type="text/javascript">
$(function() {
$("#outer").draggable({
    revert : false
    ,scroll: 'true'
    ,opacity : 1.0
});
$("#inner").draggable({
    cursor : 'pointer',
    revert : false,
    helper: 'clone'
});
});
</script>
</head>

<div id="outer">outer
<div id="inner">inner</div>

</div>

</body>
</html>


Change History (3)

comment:1 Changed 7 years ago by Scott González

Milestone: TBD2.0.0

comment:2 Changed 7 years ago by mikesherov

Owner: set to Lockhead
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI. http://jsfiddle.net/VDkF7/

If you can still reproduce it or have more information to help debug this issue, please let me know by replying to this ticket. Thanks!

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.