Opened 9 years ago

Closed 6 years ago

#5399 closed bug (duplicate)

.draggable.resizable busts container

Reported by: ollie2893 Owned by:
Priority: major Milestone: 2.0.0
Component: ui.resizable Version: 1.8
Keywords: .draggable.resizable Cc:
Blocked by: Blocking:

Description

I append a .draggable.resizable to (an unsized) .tabs panel. I can move this widget about the panel (and the panel extends as required) but as soon as I resize it, the panel collapses and the widget floats outside (and over) the panel. I looked at 1.7.2 (line 223) and 1.8 (line 244) and there's some bug fix for http://dev.jquery.com/ticket/1749 which transforms the CSS positioning (from relative to absolute) in the presence of .draggable like so:

if (el.is('.ui-draggable') | | (/absolute/).test(el.css('position'))) {

el.css({ position: 'absolute', top: iniPos.top, left: iniPos.left });

}

If I remove the first condition, like so:

if ((/absolute/).test(el.css('position'))) {

el.css({ position: 'absolute', top: iniPos.top, left: iniPos.left });

}

then the problem goes away. My .draggable.resizable widget remains relatively positioned even after the resize action and stays within the .tabs panel.

Change History (2)

comment:1 Changed 7 years ago by Scott González

Milestone: TBD2.0.0

comment:2 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #6939.

Note: See TracTickets for help on using tickets.