Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5481 closed bug (duplicate)

Datepicker adding Uneeded Height to page

Reported by: Vekz Owned by:
Priority: minor Milestone:
Component: ui.datepicker Version: 1.8
Keywords: sticky footer extra height Cc:
Blocked by: Blocking:

Description

I was trying to build a minimal site which had a date picker on it. I was using this sticky footer method http://www.cssstickyfooter.com/ It is very particular about top and bottom margins on main layout elements.

The page was rendering fine in Webkit (safari chrome) MacOs. But Firefox had hidden ~20px push at the bottom. Which was causing the page to render a scroll bar when there was no additional content.

Below is a simple example of the page structure

<html>
  <head></head>
  <body>
     <wrap></wrap>
     <footer></footer>
     <div id="ui-datepicker-div">
  </body>
</html>

since the div#ui-datepicker-div was visiblity:hidden; it was still rendering with height in FF and throwing off the footer.

The solution was to display:none the div. This allowed the datepicker and footer to function properly.

Its possible that other components would have this same issue. These extra component divs should be display:none by default.

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4111.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.