Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#5502 closed bug (duplicate)

Modal Dialog Opening Offscreen

Reported by: ThinkerR Owned by:
Priority: critical Milestone:
Component: ui.dialog Version: 1.8
Keywords: viewport scroll anchor Cc:
Blocked by: Blocking:

Description

I still have the bug of Ticket #4539.

The modal dialog will open correctly in the center of the viewport if I do not have to scroll the browser window. But if the link contains an anchor that needs some scrolling, the dialog box will open offscreen, at the top of the page.

To reproduce the viewport problem with attached file, type the url modal-message.html#anchor in Chrome 5.0.342.9 beta for Ubuntu.

Attachments (1)

modal-message.html (3.2 KB) - added by ThinkerR 10 years ago.
Slightly modified demo example of modal-message.html

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by ThinkerR

Attachment: modal-message.html added

Slightly modified demo example of modal-message.html

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Closing as duplicate of #4539. The problem is exactly as I stated there: the browser isn't scrolling down to the anchor until after document ready fires. The code is working properly. You can verify this yourself by checking $( window ).scrollTop() inside the $(document).ready() event and again after a 1ms delay.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.