Opened 9 years ago

Closed 7 years ago

#5506 closed bug (fixed)

effect('highlight') produces exception in chrome on detached object

Reported by: mkowalski Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.effects.core Version: 1.7
Keywords: Cc: mkowalski@…
Blocked by: Blocking:

Description

chrome version: Chromium 5.0.372.0 (44042) Ubuntu

code to reproduce:

var element = $('#some-existing-id');
element.detach();
element.effect('highlight');

This code produces uncaught exception:

Cannot get property 0 of undefined.

On every other browser we the following behavior: since item is not visible on the page nothing happens. Workaround: check if element is visible before calling effect

if (item.is(':visible')) {

...

}

Change History (3)

comment:1 Changed 9 years ago by Jörn Zaefferer

Component: ui.coreeffects.core

comment:2 Changed 8 years ago by Corey Frang

Status: newopen

http://bugs.jqueryui.com/ticket/5506 - Seems to be that highlight effect is grabbing the elements backgroundColor before animating it - upcoming changes in jQuery-color will help here...

comment:3 Changed 7 years ago by Scott González

Milestone: TBD1.9.0
Resolution: fixed
Status: openclosed

This is working in master.

Note: See TracTickets for help on using tickets.