Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#5515 closed bug (duplicate)

autocomplete - Firefox, leaving cursor over result set while typing overwrites typed text

Reported by: dmiranda Owned by:
Priority: minor Milestone:
Component: ui.autocomplete Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

In Firefox (tested in 3.6.2).

Reproducible on jQuery UI autocomplete demo page: http://jqueryui.com/demos/autocomplete/

Step 1) Give the autocomplete input focus. Step 2) Move the cursor over to where an item in the autocomplete suggest will appear once the user starts entering text (usally just below the autocomplete input field) Step 3) Start typing text in the autocomplete input box. The box will automatically fill with whatever item the cursor is floating over. For instance, on the demo page, typing "a" with the cursor left over where the first item appears, "java", will change the text in the input field to "java", regardless of whether or not the user actually the third item in the list "asp".

This does not occur in IE7 or Chrome.

Change History (4)

comment:1 Changed 9 years ago by Arnold42

This behaviour might be by design. Can be turned off by adding:

focus: function(event, ui) { return false; },

comment:2 Changed 9 years ago by johnk_c4b

This appears to be fixed in 1.8.1

comment:3 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5349.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.