Opened 9 years ago

Closed 7 years ago

#5524 closed bug (duplicate)

Tabbing quickly through datepicker-enabled field leaves calendar stuck

Reported by: dlee Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

When I tab into a datepicker-enabled field, the calendar correctly pops up. When I tab away, the calendar disappears, but if I tab away too quickly (while the calendar is growing), the calendar remains up.

Reproduce this by tabbing in and then quickly tabbing out of a datepicker-enabled field.

Change History (3)

comment:1 Changed 9 years ago by kbwood

The visibility flag is set too late - so make this change to _showDatepicker function:

			var postProcess = function() {
//				$.datepicker._datepickerShowing = true; // Remove from here
				var borders = $.datepicker._getBorders(inst.dpDiv);
				inst.dpDiv.find('iframe.ui-datepicker-cover'). // IE6- only
					css({left: -borders[0], top: -borders[1],
						width: inst.dpDiv.outerWidth(), height: inst.dpDiv.outerHeight()});
			};
			inst.dpDiv.zIndex($(input).zIndex()+1);
			$.datepicker._datepickerShowing = true; // And add it here

comment:2 Changed 7 years ago by Scott González

Milestone: TBD1.11.0

comment:3 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #6775.

Note: See TracTickets for help on using tickets.