Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5530 closed bug (duplicate)

Autocomplete and firing select off menu click

Reported by: mattcowen Owned by:
Priority: major Milestone:
Component: ui.autocomplete Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

When selecting a menu item on the Autocomplete widget, if the user clicks slowly, i.e. mouse down, pause and mouse up, the select method is not triggered. This method should triggered on mouse up and only if the menu item still has focus.

Thanks Matt

Change History (3)

comment:1 Changed 10 years ago by snives

Tested in 1.8.1 and the bug still remains. I was able to consistently reproduce it by clicking a fraction of a second slower than normal, which may be common for some users. Seems this is due to an internal race condition/timing within ui.autocomplete when selecting the item via the mouse. It does seem odd that it should do anything on mousedown, instead it should just select on the mouseup. It seems like this bug is related to Ticket #5405 also. Need fix asap please.

comment:2 Changed 10 years ago by Jörn Zaefferer

Resolution: duplicate
Status: newclosed

Duplicate of #5405.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.