Opened 9 years ago

Closed 9 years ago

#5533 closed bug (wontfix)

Position fails when no top value is set for absolute in IE

Reported by: epascarello Owned by:
Priority: major Milestone: 1.9.0
Component: ui.position Version: 1.8
Keywords: position IE8 IE7 absolute Cc:
Blocked by: Blocking:

Description (last modified by Scott González)

If you have an element that is positioned absolutely and you use position. It has to have a top value set. If it is left off, IE7/8 will position the element in the wrong page location.

Test Code can be found here: http://jsbin.com/eviki4/4/

Attachments (1)

positionBug.html (2.2 KB) - added by epascarello 9 years ago.
Example Code showing bug in IE

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by epascarello

Attachment: positionBug.html added

Example Code showing bug in IE

comment:1 Changed 9 years ago by Jörn Zaefferer

Milestone: TBD1.9
Priority: minormajor

comment:2 Changed 9 years ago by Scott González

This is fixed with jQuery 1.4.3 (unreleased). The problem is actually in jQuery's offset setter. See http://dev.jquery.com/ticket/5781.

comment:3 Changed 9 years ago by Scott González

Description: modified (diff)
Resolution: wontfix
Status: newclosed

The workaround for this is to just do .css({ top: 0, left: 0 }).position({...}) which is what we do in all of the jQuery UI plugins. We won't fix this in the position plugin, just use the workaround until jQuery 1.4.3 is released.

Note: See TracTickets for help on using tickets.