Opened 10 years ago

Closed 9 years ago

#5551 closed bug (fixed)

Inconsistent values returned by range slider

Reported by: rmckillen Owned by:
Priority: major Milestone: 1.8.1
Component: ui.slider Version: 1.7.2
Keywords: range values Cc:
Blocked by: Blocking:

Description

My issue appears related to previously closed ticket #5132.

Range sliders seem to return inconsistent values:

  • When the left handle is dragged, the count begins at 1.
  • When the right handle is dragged, the count begins at 0.
  • And in cases where the handles are attempted to be dragged on top of on another, the min and max values returned are the same, event though the slider shows a range--not single point--selection.

See attached screenshot taken from the URL shared in ticket #5132 and note how 3 different sets of values are being reported for what looks to be an identical range.

Is this the intended behavior?

If so, I feel that I'll have to build an additional layer of value handling to deal with left-handle/right-handle/single-point scenarios to adjust the values accordingly and return a consistent range.

Attachments (1)

slider_ranges.gif (5.1 KB) - added by rmckillen 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by rmckillen

Attachment: slider_ranges.gif added

comment:1 Changed 10 years ago by rmckillen

As of 1.8.1, this appears to be fixed. Thanks. Ticket should be closed.

comment:2 Changed 9 years ago by Scott González

Milestone: TBD1.8.1
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.