Opened 9 years ago

Closed 6 years ago

#5558 closed bug (worksforme)

Draggable: Selecting the text within the delay draggable demo causes the draggable to drug until you left click

Reported by: wgoldman Owned by: wgoldman
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

Steps to reproduce; 1) Goto http://jqueryui.com/demos/draggable/#delay-start, 2) Using the mouse select the 'O' in the box containing this text 'Only if you drag me by 20 pixels, the dragging will start', 3) While holding the shift key down and press the down arrow 3 times, 4) Using the mouse left click the draggable with the text highlighted and drag somewhere (should see a circle with diagonal line), 5) Release the left mouse button.

Draggable remains drug until you left click again. This behaviour is not consistent with the behaviour exhibited when text is not selected.

Change History (4)

comment:1 Changed 6 years ago by Scott González

Milestone: TBD2.0.0

comment:2 Changed 6 years ago by petersendidit

Owner: set to wgoldman
Status: newpending
Summary: Selecting the text within the delay draggable demo causes the draggable to drug until you left clickDraggable: Selecting the text within the delay draggable demo causes the draggable to drug until you left click

Thanks for taking the time to contribute to the jQuery UI project! Which browser version did you see this problem in. I was unable to see the problem in Chrome 22 and Firefox 16

comment:3 Changed 6 years ago by wgoldman

Status: pendingnew

Since that was 3 years ago, the browser version I used has now become irrelevant. Just the same, I was using either IE or Firefox and whatever version would have been current for the time.

comment:4 Changed 6 years ago by mikesherov

Resolution: worksforme
Status: newclosed

Since we can no longer reproduce this issue ( I just tested this in IE7-10), I'm going to mark this ticket as worksforme, although I'm sure it was probably broken 3 years ago :-) wgoldman, thanks for replying to this ticket, even 3 years later!

Note: See TracTickets for help on using tickets.