Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#5570 closed bug (worksforme)

Problem when dialog are resizable and the content overfow

Reported by: Daazku Owned by:
Priority: minor Milestone:
Component: ui.dialog Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

The bottom scrollbar is partially hidden because the min-height of the content isn't small enough.

To quickly fix that i just do

@@ -6009,7 +6012,8 @@
 
         this.element
             .css(options.height === 'auto' ? {
-                    minHeight: Math.max(options.minHeight - nonContentHeight, 0),
+                    //We add remove 16px to handle scrollbar
+                    minHeight: Math.max(options.minHeight - nonContentHeight - 16, 0),
                     height: 'auto'
                 } : {
                     minHeight: 0,

Change History (4)

comment:1 Changed 10 years ago by Daazku

The issue is not ui.core but ui.dialog

My bad.

comment:2 Changed 9 years ago by Jörn Zaefferer

Component: ui.coreui.dialog

comment:3 Changed 9 years ago by Scott González

Resolution: worksforme
Status: newclosed

Works fine for me in 1.8.0 and current master. Tested in Chrome dev, Firefox 3.6, IE 6.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.