Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#5578 closed bug (notabug)

Found Something - dblclick with slide

Reported by: mrcullers Owned by:
Priority: major Milestone:
Component: ui.slider Version: 1.8rc3
Keywords: Slide Double Click 2 instances Cc:
Blocked by: Blocking:

Description

Problem listed at the bottom of all of this....

Starts with this....

<div class="switchup" id="closeDesktop" onclick="$('#openDesktop').fadeIn();$('#DTLayer1').hide('slide',,800); $(this).hide();" ></div> <div class="switchdown" id="openDesktop" onclick="$('#DTLayer1').show('slide',,800); $('#closeDesktop').fadeIn(); $(this).hide();" style="display:none;"></div>

used with....

<script type="text/javascript">

$(document).ready(function() {

$(".doubleClickable").dblclick(function(){ alert('ID ' + this.id + ' has been double clicked! '); });

});

$(document).ready(function() {

$(".Icons").draggable({

containment: '.IconSpace', scroll: false

}).mousemove(function(){

var coord = $(this).position(); $("p:last",this).text( "left: " + coord.left + ", top: " + coord.top );

}).mouseup(function(){

var coords=[]; var coord = $(this).position(); var item={ coordTop: coord.left, coordLeft: coord.top };

coords.push(item);

var order = {id:this.id, coords: coords }; $.post('ajax.com.channel.2.php', 'data='+$.toJSON(order), function(response){

$('#ComChannel1Log').prepend('<ul><li>» <b>Server Response:</b> common core desktop shit</li></ul>'); });

});

});

</script>

In this element I have also.....

$('#draggable').draggable(

{ revert: 'valid', containment: '#resizableDesktop' }

);

$('.trashcan').droppable({

hoverClass: 'deleteMe2', drop: function(event, ui) {

$('.trashcan').addClass('deleteMe3');

$.doTimeout('timeoutid3',400,function(){ $('.trashcan').removeClass('deleteMe3'); });

}

});

";

The issue is as follows....

I originally had the dblclick() in with the rest of the code but I separated it while investigating the problem.

Anyway... ONLY when I click on slide does it happen. After click on slide, all double clicks for some reason act as happening twice. Meaning on DOM load I can double click all day long and interact with anything else on the page, and I have managed to use almost every possible element in the jQuery package as I am making an internet program that acts as an OS desktop. Again, only when I execute slide does the double click function cause 2 instances of the double click to occur.

Change History (4)

comment:1 Changed 10 years ago by mrcullers

Furthermore....

I am assuming that show/slide is the problem. I have, like I said, every possible UI effect in play along with 10 other plugins. It is mixed with Mb Containers plus, along with most of the mb container functions re-programmed to my liking. Reason is because only the sites main css frame is downloaded normally. This site/program is 99% ajax driven, from mbcontainers serving as exe-like popups via ajax with everything in between.

I have waited a while before submitting this just to make sure it wasn't me. And thus far I have only 3 issues.

1) Slide + draggable item + double click = 2 instances of double click. 2) Tabs only works when separated from the min file and placed last. 3) DOM memory leaks still showing up after remove(). using JQ 1.4.2

Thanks

comment:2 Changed 10 years ago by mrcullers

Also tested under 1.8 rc3 and 1.8 stable.... same set of problems

comment:3 Changed 10 years ago by Scott González

Resolution: invalid
Status: newclosed

There's not enough information here. Your problem is with double click, but your code doesn't have any elements with double click bound to them. Please ask for help on the forums and provide a simplified, working, test case.

comment:4 Changed 8 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.