Opened 10 years ago

Closed 7 years ago

#5632 closed bug (duplicate)

setting dateFormat and minDate with 4 digit year cause erroneous dates to be displayed

Reported by: sroughley Owned by:
Priority: major Milestone: 1.11.0
Component: ui.datepicker Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

Using the following .datepicker({ minDate: '31/05/2010', dateFormat: 'dd/mm/yy', ...

Causes datePicker to display a min date of December 25th 2015. Tracked issue down to parseDate->getNumber->lookAhead. Doesn't seem to account for 4 digit years

Change History (3)

comment:1 Changed 9 years ago by Jörn Zaefferer

Component: ui.coreui.datepicker

comment:2 Changed 7 years ago by Scott González

Milestone: TBD1.11.0

comment:3 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #6659.

Note: See TracTickets for help on using tickets.