Opened 9 years ago

Closed 8 years ago

#5642 closed bug (fixed)

tabs broken in IE7 with async set to false

Reported by: dclangan Owned by:
Priority: major Milestone: 1.8.1
Component: ui.tabs Version: 1.8.1
Keywords: ie7 async Cc:
Blocked by: Blocking:

Description

When using async: false for ajaxOptions, all tab interactions break after selecting the dynamically loaded tab in IE7.

To reproduce: -Create Tabs with async set to false for ajaxOptions
-load a new tab via ajax
-select newly created tab
-notice you can no longer interact with tabs and there is a js error

Attached is an example which reproduces the issue. This problem did not exist when using jQuery 1.3.2 with jQuery UI 1.7.2

Attachments (1)

tab_example.zip (1.5 KB) - added by dclangan 9 years ago.
IE7 broken tabs example

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by dclangan

Attachment: tab_example.zip added

IE7 broken tabs example

comment:1 Changed 9 years ago by olaechea

This bug is caused by http://bugs.jquery.com/ticket/7018 in jquery, if you apply the patch https://github.com/jquery/jquery/pull/36 (e.g https://github.com/csnover/jquery/commit/d2e64979bf641181443a8e6456f6292973a7fa9a ) then this bug is fixed.

We had the tabs not working in IE7 , then applied the patch to our jquery and it worked fine.

comment:2 Changed 8 years ago by Scott González

Milestone: TBD1.8.1
Resolution: fixed
Status: newclosed

The bug was fixed in jQuery core. Thanks olaechea for tracking this down.

Note: See TracTickets for help on using tickets.