Opened 9 years ago

Closed 7 years ago

#5649 closed bug (duplicate)

Dialog: multiple modal dialog zindex conflicts

Reported by: L_K_W Owned by:
Priority: major Milestone: 1.10.0
Component: ui.dialog Version: 1.8.1
Keywords: overlay Cc:
Blocked by: Blocking:

Description (last modified by Jörn Zaefferer)

Look at the following code in the ui.dialog file:

$(document).bind($.ui.dialog.overlay.events, function(event) {
// stop events if the z-index of the target is < the z-index of the overlay
    return ($(event.target).zIndex() >= $.ui.dialog.overlay.maxZ);
});

The value of '$.ui.dialog.overlay.maxZ' will be changed if a second modal dialog opend and this will cause the events handler return false. For example, if you click a radio on the first dialog to open a new second dialog, this raido will never be checked.

I think we should use a tmp var saved before the bind operation.

Change History (5)

comment:1 Changed 8 years ago by Scott González

Keywords: reuse coupling removed

comment:2 Changed 7 years ago by Scott González

Milestone: TBD1.10.0

comment:3 Changed 7 years ago by petersendidit

Status: newopen
Summary: overlay reuse coupling problemDialog: multiple modal dialog zindex conflicts

comment:4 Changed 7 years ago by Jörn Zaefferer

Description: modified (diff)

comment:5 Changed 7 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #8172.
Closing as duplicate of the newer ticket because the description in the newer ticket is much better and it contains a test case.

Note: See TracTickets for help on using tickets.