Opened 9 years ago

Closed 7 years ago

#5656 closed bug (invalid)

peculiarity with right-aligned sortable items

Reported by: fajeuqwrhf Owned by: fajeuqwrhf
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.1
Keywords: right Cc:
Blocked by: Blocking:

Description

When assigning Sortable to a list of horizontal right-aligned items (by "float: right" or by "direction:rtl"), it does not work as expected and react strangely to the user's actions.

For example, go to here: http://jqueryui.com/demos/sortable/display-grid.html and change the css to #sortable li { float: right; }

Change History (5)

comment:1 Changed 8 years ago by wael34218

Last edited 8 years ago by wael34218 (previous) (diff)

comment:2 Changed 8 years ago by jenyay

I'm having the same issue when items has float set to right. The bug can be viewed here: http://jsfiddle.net/jenyay/2VHnp/

comment:3 Changed 7 years ago by Scott González

Milestone: TBD2.0.0

comment:4 Changed 7 years ago by mikesherov

Owner: set to fajeuqwrhf
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI using the info provided. http://jsfiddle.net/7mkEg/1/

If you can still reproduce it, please feel free to reply to this ticket with a test case showing the problem. Thanks!

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.