Opened 9 years ago

Closed 7 years ago

#5658 closed bug (duplicate)

Datepicker not positioned for only-child hidden inputs

Reported by: andyfowler Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.1
Keywords: hidden Cc:
Blocked by: Blocking:

Description

When a datepicker is applied to a hidden input, datepicker._findPos() tries to seek for the next visible sibling. If there are no siblings, it fails.

Pseudocode example:

<div><input id="date-me" type="hidden datepicker">Asdf</div>
<script>
$('#date-me').datepicker();
</script>

Yields a non-positioned datepicker. I've patched this on my Github fork. As soon as I get a ticket ID here, I'll post a link.

Attachments (1)

0001-fixes-5658-bad-positioning-for-only-child-hidden-inp.patch (1.2 KB) - added by andyfowler 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:3 Changed 8 years ago by brazir

wish i saw this sooner. is this patch supposed to be in place as I still see the problem as of 1.8.14

comment:4 Changed 7 years ago by Scott González

Milestone: TBD1.11.0

comment:5 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #6988.

Note: See TracTickets for help on using tickets.