Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5660 closed bug (fixed)

Clicking slowly doesn't trigger select event

Reported by: nickknw Owned by:
Priority: critical Milestone: 1.8.2
Component: ui.autocomplete Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

Reproduce:

  1. Go to autocomplete demo: http://jqueryui.com/demos/autocomplete/
  2. Type a j in the box. The autocomplete list should appear as normal.
  3. Pretend you are a user unfamiliar with computers and click slowly and deliberately on 'java'. (Or just mousedown and hold)
  4. The autocomplete box disappears and 'java' is not selected.

Result: Users that do not click very quickly cannot use the autocompleter at all.

Browsers: All, as far as I can tell.

This is pretty urgent for our site and I will be trying to dig around to see if I can fix it myself, but it may take me quite a while as I'm not super fluent in javascript or the jQuery source.

I would appreciate any help anyone can spare.

Thanks,
Nick

Change History (4)

comment:1 Changed 9 years ago by nickknw

This is meant to be on the autocomplete component, sorry, I fail at trac.

comment:2 Changed 9 years ago by rdworth

Milestone: TBD1.8.2
Resolution: fixed
Status: newclosed

Duplicate of #5405

comment:3 Changed 9 years ago by rdworth

Component: ui.coreui.autocomplete

comment:4 Changed 9 years ago by nickknw

Resolution in 5405 works for me as well, thanks for letting me know about that. I guess I should have searched first, instead of just looking through the open bugs. Thanks again!

Note: See TracTickets for help on using tickets.