Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5684 closed bug (notabug)

Problem with draggable/droppble when droppables are inside scrollable div

Reported by: bhavnik Owned by:
Priority: minor Milestone:
Component: ui.droppable Version: 1.8.1
Keywords: invisible droppable, scrollabe div Cc: bhavnik.gajjar@…
Blocked by: Blocking:

Description

Hi,

I have droppable elements inside a DIV. This is a scrollable DIV as lot of droppable elememnts (ui) are there.

The drop accept begins even after a draggable item is dropped below this scrolling DIV. Note that, item is dropped even no droppable is visible (since, they are actually in DIV with scrollbar).

Can anybody please look into this problem?

Please excuse me if this is not a bug (and, advise me the fix in this case).

Looking for reply eagerly.

Thanks,

Bhavnik

Change History (3)

comment:1 Changed 10 years ago by rdworth

Resolution: invalid
Status: newclosed

Please post first to the forum http://forum.jquery.com/using-jquery-ui with enough information for us to easily see what you're seeing. Best is a link to a live sample page showing the problem. If you don't have a way to host one, use http://jsbin.com/ . If there it's determined to be a bug, then create or reopen here.

comment:2 Changed 9 years ago by nickspacek

I think I have the same issue, I posted in the forum here: http://forum.jquery.com/topic/fixed-size-sortable-with-overflow-auto-does-not-scroll

And here is the example: http://jsfiddle.net/PsFT8/

Add a few items to the sortable (the blue area). Once it overflows, I'd like it to scroll when dragging another item to it, but I can't get that behavior to work. Is it possible?

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.